Redmine läuft nach Upgrade auf Ubuntu 10.04 Lucid Lynx nicht mehr

Nach einem reibungslosen Upgrade auf Ubuntu 10.04 (Lucid Lynx) wollte meine Redmine-Installation nicht mehr. In der entsprechenden Log-Datei fand sich der folgende Hinweis:

/usr/lib/ruby/1.8/x86_64-linux/RMagick2.so: This installation of RMagick was configured with ImageMagick 6.5.5 but ImageMagick 6.5.7-8 is in use. (RuntimeError)

Der Fehler lies sich  relativ schnell beheben, indem man in die Datei /var/www/rails_apps/redmine/0.8.7/config/boot.rb die Zeile

RMAGICK_BYPASS_VERSION_TEST = true

am Anfang einfügt. Etwaige Nebeneffekte sind mir nicht bekannt.

5 Gedanken zu „Redmine läuft nach Upgrade auf Ubuntu 10.04 Lucid Lynx nicht mehr“

  1. Nach dem reibungslosen Update auf 10.04 nutze ich wieder Windows XP.

  2. Wie kommt’s? Ist das unsägliche Standard-Theme erst einmal ausgeschaltet, läuft eigentlich alles wie bisher. Die richtig großen Unterschiede habe ich jetzt nicht feststellen können. (Oder ist das der Grund? ;-)

  3. Meine Themeeinstellungen wurden sogar übernommen, nach dem Distributionsupdate merkte ich tatsächlich kaum einen Unterschied. Es ist eher so, dass einige Dinge immer noch nicht funktionieren und das eigentlich nur der Anlass war, wieder zurückzuwechseln. Und das ist eine ganze Liste von Dingen (“paper cuts”), die mich nerven, die von den Vorteile nicht aufgewogen werden. Ich schreib mal selber einen Blogeintrag dazu ^^. Erster Eintrag “Anti-Linux”, sollte das jemand lesen, habe ich auch gleich die richtige Klientel…
    Das Zurückwechseln zu XP war auch nicht so problematisch, einfach die andere Platte angestöpselt (und Updates gezogen). Wieder wechseln ist entsprechend einfach, jetzt sogar in Grub.

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>